Libraries

Libraries that have been created for interaction with the Discord Extreme List API

NOTICE: We do not update these libraries ourselves, these libraries may be outdated now when they weren't at the time of writing this.

Node.JS (NPM)

This API package has been marked as critically out of date by DEL. It will not work.

Please look at our serverCount Examples for an up-to-date and working serverCount example.

const DEL = require('discordextremelist.xyz');
const client = new DEL.Client('Bot ID', 'API Token');
client.getBot('507970352501227523').then((bot) => {
console.log(bot);
}).catch((e) => {
console.error(e);
});
client.getUser('478255216588750858').then((user) => {
console.log(user);
}).catch((e) => {
console.error(e);
});
client.getWidget('507970352501227523').then((widget) => {
console.log(widget);
}).catch((e) => {
console.error(e);
});
client.updateCount(123).then((bot) => {
console.log('Server count has been updated', bot);
}).catch((e) => {
console.error(e);
});